Differences in Revisions: CompuLab Utilite

fix code blocks
# CompuLab Utilite
 
## Support
 
CompuLab sponsored one Utilite to the IPFire project. Unfortunately there is no working support for IPFire, yet (as of February 2015). It may be well possible that support for IPFire will never get stable as the main issue is lack of support for the hardware in the Linux kernel and buggy firmware on the device itself as well as a missing u-boot bootloader.
 
A successor called Utilite 2 is already available for purchase.
 
## Hardware Issues
 
### Ethernet
 
The Intel adapters won't work because there is no EEPROM with a MAC address which is required by the module to start.
 
### Wireless (mwifiex_sdio)
 
```
[ 14.800355] mwifiex_sdio mmc0:0001:1: mwifiex_cmd_timeout_func: Timeout cmd id = 0xa9, act = 0x0
[ 14.800355] mwifiex_sdio mmc0:0001:1: mwifiex_cmd_timeout_func: Timeout cmd id = 0xa9, act = 0x0
[ 14.800369] mwifiex_sdio mmc0:0001:1: num_data_h2c_failure = 0
[ 14.800369] mwifiex_sdio mmc0:0001:1: num_data_h2c_failure = 0
[ 14.800381] mwifiex_sdio mmc0:0001:1: num_cmd_h2c_failure = 0
[ 14.800381] mwifiex_sdio mmc0:0001:1: num_cmd_h2c_failure = 0
[ 14.800392] mwifiex_sdio mmc0:0001:1: is_cmd_timedout = 1
[ 14.800392] mwifiex_sdio mmc0:0001:1: is_cmd_timedout = 1
[ 14.800407] mwifiex_sdio mmc0:0001:1: num_tx_timeout = 0
[ 14.800407] mwifiex_sdio mmc0:0001:1: num_tx_timeout = 0
[ 14.800420] mwifiex_sdio mmc0:0001:1: last_cmd_index = 1
[ 14.800420] mwifiex_sdio mmc0:0001:1: last_cmd_index = 1
[ 14.800429] mwifiex_sdio mmc0:0001:1: last_cmd_id: 00 00 a9 00 00 00 00 00 00 00
[ 14.800429] mwifiex_sdio mmc0:0001:1: last_cmd_id: 00 00 a9 00 00 00 00 00 00 00
[ 14.800437] mwifiex_sdio mmc0:0001:1: last_cmd_act: 00 00 00 00 00 00 00 00 00 00
[ 14.800437] mwifiex_sdio mmc0:0001:1: last_cmd_act: 00 00 00 00 00 00 00 00 00 00
[ 14.800451] mwifiex_sdio mmc0:0001:1: last_cmd_resp_index = 0
[ 14.800451] mwifiex_sdio mmc0:0001:1: last_cmd_resp_index = 0
[ 14.800459] mwifiex_sdio mmc0:0001:1: last_cmd_resp_id: 00 00 00 00 00 00 00 00 00 00
[ 14.800459] mwifiex_sdio mmc0:0001:1: last_cmd_resp_id: 00 00 00 00 00 00 00 00 00 00
[ 14.800467] mwifiex_sdio mmc0:0001:1: last_event_index = 0
[ 14.800467] mwifiex_sdio mmc0:0001:1: last_event_index = 0
[ 14.800474] mwifiex_sdio mmc0:0001:1: last_event: 00 00 00 00 00 00 00 00 00 00
[ 14.800474] mwifiex_sdio mmc0:0001:1: last_event: 00 00 00 00 00 00 00 00 00 00
[ 14.800481] mwifiex_sdio mmc0:0001:1: data_sent=1 cmd_sent=1
[ 14.800481] mwifiex_sdio mmc0:0001:1: data_sent=1 cmd_sent=1
[ 14.800489] mwifiex_sdio mmc0:0001:1: ps_mode=0 ps_state=0
[ 14.800489] mwifiex_sdio mmc0:0001:1: ps_mode=0 ps_state=0
[ 14.800516] mwifiex_sdio mmc0:0001:1: cmd timeout
[ 14.800516] mwifiex_sdio mmc0:0001:1: cmd timeout
[ 14.800576] mwifiex_sdio: Resetting card...
[ 14.800576] mwifiex_sdio: Resetting card...
```
 
### USB won't work
 
```
`Jan 1 01:01:28 ipfire-utilite kernel: usb 1-1: USB disconnect, device number 2`
Jan 1 01:01:28 ipfire-utilite kernel: usb 1-1: USB disconnect, device number 2
`Jan 1 01:01:29 ipfire-utilite kernel: hub 1-0:1.0: cannot reset port 1 (err = -32)`
Jan 1 01:01:29 ipfire-utilite kernel: hub 1-0:1.0: cannot reset port 1 (err = -32)
`Jan 1 01:01:29 ipfire-utilite last message repeated 4 times`
Jan 1 01:01:29 ipfire-utilite last message repeated 4 times
`Jan 1 01:01:29 ipfire-utilite kernel: hub 1-0:1.0: Cannot enable port 1. Maybe the USB cable is bad?`
Jan 1 01:01:29 ipfire-utilite kernel: hub 1-0:1.0: Cannot enable port 1. Maybe the USB cable is bad?
`Jan 1 01:01:29 ipfire-utilite kernel: hub 1-0:1.0: cannot reset port 1 (err = -32)`
Jan 1 01:01:29 ipfire-utilite kernel: hub 1-0:1.0: cannot reset port 1 (err = -32)
`Jan 1 01:01:29 ipfire-utilite last message repeated 4 times`
Jan 1 01:01:29 ipfire-utilite last message repeated 4 times
`Jan 1 01:01:29 ipfire-utilite kernel: hub 1-0:1.0: Cannot enable port 1. Maybe the USB cable is bad?`
Jan 1 01:01:29 ipfire-utilite kernel: hub 1-0:1.0: Cannot enable port 1. Maybe the USB cable is bad?
`Jan 1 01:01:29 ipfire-utilite kernel: hub 1-0:1.0: cannot reset port 1 (err = -32)`
Jan 1 01:01:29 ipfire-utilite kernel: hub 1-0:1.0: cannot reset port 1 (err = -32)
`Jan 1 01:01:29 ipfire-utilite last message repeated 4 times`
Jan 1 01:01:29 ipfire-utilite last message repeated 4 times
`Jan 1 01:01:29 ipfire-utilite kernel: hub 1-0:1.0: Cannot enable port 1. Maybe the USB cable is bad?`
Jan 1 01:01:29 ipfire-utilite kernel: hub 1-0:1.0: Cannot enable port 1. Maybe the USB cable is bad?
`Jan 1 01:01:29 ipfire-utilite kernel: hub 1-0:1.0: cannot reset port 1 (err = -32)`
Jan 1 01:01:29 ipfire-utilite kernel: hub 1-0:1.0: cannot reset port 1 (err = -32)
`Jan 1 01:01:29 ipfire-utilite last message repeated 4 times`
Jan 1 01:01:29 ipfire-utilite last message repeated 4 times
`Jan 1 01:01:29 ipfire-utilite kernel: hub 1-0:1.0: Cannot enable port 1. Maybe the USB cable is bad?`
Jan 1 01:01:29 ipfire-utilite kernel: hub 1-0:1.0: Cannot enable port 1. Maybe the USB cable is bad?
`Jan 1 01:01:29 ipfire-utilite kernel: hub 1-0:1.0: unable to enumerate USB device on port 1`
Jan 1 01:01:29 ipfire-utilite kernel: hub 1-0:1.0: unable to enumerate USB device on port 1
```