IPSec Update

In the IPFire Version 2.7 the software for IPSec VPN will change form Openswan to Strongwan.

Here we describe what you have to do after an update form a previous version of IPFire to 2.7.
You can perform these changes even before an update, so you bypass error messages after a reboot of the system after the upgrade.
This change affects no connections with certificates!

For the work of Strongwan, the fields Local ID and Remote ID are mandatory for PSK and therefore must be filled up.

To modify an existing connection click onEdit (pin):

In the now appearing window the fields Local ID and Remote ID have to be filled up:

The entry must begin with a @. To make it easier we recommend to use the hostname of the connection. These entries must be entered on both sides of the VPN and have to be identically.
The Local ID must be the name as the name on the opposite side for Remote ID and vice versa.

After the changes are done click onSave.

The IPSec module will restart and the connection should show

.

Edit Page ‐ Yes, you can edit!

Older Revisions • September 18, 2018 at 12:07 am • Jon